一、单区域OSPF
OSPF(Open Shortest Path First开放式最短路径优先)是一个内部网关协议(Interior Gateway Protocol,简称IGP),用于在单一自治系统(autonomous system,AS)内决策路由。
拓扑结构如图8-11所示。
1.项目步骤
配置路由器的端口地址,并设置时钟频率。(具体操作略)
1配置路由器R1。
R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 1.1.1.0 255.255.255.0 area 0
R1(config-router)#network 192.168.12.0 255.255.255.0 area 0
2配置路由器R2。
R2(config)#router ospf 1
R2(config-router)#router-id 2.2.2.2
R2(config-router)#network 192.168.12.0 255.255.255.0 area 0
R2(config-router)#network 192.168.23.0 255.255.255.0 area 0
R2(config-router)#network 2.2.2.0 255.255.255.0 area 0
3配置路由器R3。
R3(config)#router ospf 1
R3(config-router)#router-id 3.3.3.3
R3(config-router)#network 192.168.23.0 255.255.255.0 area 0
R3(config-router)#network 192.168.34.0 255.255.255.0 area 0
R3(config-router)#network 3.3.3.0 255.255.255.0 area 0
4配置路由器R4。
R4(config)#router ospf 1
R4(config-router)#router-id 4.4.4.4
R4(config-router)#network 4.4.4.0 0.0.0.255 area 0
R4(config-router)#network 192.168.34.0 0.0.0.255 area 0
2.项目调试
R2#show ip route
Gateway of last resort is not set
C 192.168.12.0/24 is directly connected, Serial0/1/0 1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/782] via 192.168.12.1, 00:18:40, Serial0/1/0 2.0.0.0/24 is subnetted, 1 subnets
C 2.2.2.0 is directly connected, Loopback0 3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/782] via 192.168.23.3, 00:18:40, Serial0/1/1 4.0.0.0/32 is subnetted, 1 subnets
O 4.4.4.4 [110/1563] via 192.168.23.3, 00:18:40, Serial0/1/1
C 192.168.23.0/24 is directly connected, Serial0/0/1
O 192.168.34.0/24 [110/1562] via 192.168.23.3, 00:18:41, Serial0/0/1
输出结果表明同一个区域内通过OSPF 路由协议学习的路由条目用代码“O”表示。
说明:
①环回接口OSPF路由条目的掩码长度都是32位,这是环回接口的特性,尽管通告了24位,解决的办法是在环回接口下修改网络类型为“Point-to-Point”,操作如下:
R2(config)#interface loopback 0
R2(config-if)#ip ospf network point-to-point
这样收到的路由条目的掩码长度和通告的一致。
②路由条目“4.4.4.4”的度量值为1563,计算过程如下:
cost 的计算公式为108/带宽(bps),然后取整,而且是所有链路入口的cost之和,环回接口的cost为1,路由条目“4.4.4.4”到路由器R2 经过的入接口包括路由器R4的loopback0,路由器R3的s0/1/0,路由器R2的s0/1/1,所以计算如下:1 + 108/128000 + 108/128000 = 1563。也可以直接通过命令“ip ospf cost”设置接口的cost值,并且它是优先计算的cost值的。
二、多区域OSPF
拓扑结构如图8-12所示。
配置时采用环回接口尽量靠近区域0 的原则。路由器R4 的环回接口不在OSPF 进程中通告,通过重分布的方法进入OSPF 网络。
1.项目步骤
配置路由器的端口地址,并设置时钟频率。(具体操作略)
1配置路由器R1。
R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 1.1.1.0 255.255.255.0 area 1
R1(config-router)#network 192.168.12.0 255.255.255.0 area 1
2配置路由器R2。
R2(config)#router ospf 1
R2(config-router)#router-id 2.2.2.2
R2(config-router)#network 192.168.12.0 255.255.255.0 area 1
R2(config-router)#network 192.168.23.0 255.255.255.0 area 0
R2(config-router)#network 2.2.2.0 255.255.255.0 area 0
3配置路由器R3。
R3(config)#router ospf 1
R3(config-router)#router-id 3.3.3.3
R3(config-router)#network 192.168.23.0 255.255.255.0 area 0
R3(config-router)#network 192.168.34.0 255.255.255.0 area 2
R3(config-router)#network 3.3.3.0 255.255.255.0 area 0
4配置路由器R4。
R4(config)#router ospf 1
R4(config-router)#router-id 4.4.4.4
R4(config-router)#network 192.168.34.0 0.0.0.255 area 2
R4(config-router)#redistribute connected subnets !将直连路由重分布到OSPF 网络
2.项目调试
R2#show ip route ospf
1.0.0.0/24 is subnetted, 1 subnets
O 1.1.1.0 [110/65] via 192.168.12.1, 00:04:36, Serial0/1/0 3.0.0.0/24 is subnetted, 1 subnets
O 3.3.3.0 [110/65] via 192.168.23.3, 00:02:46, Serial0/1/1 4.0.0.0/24 is subnetted, 1 subnets
O E2 4.4.4.0 [110/20] via 192.168.23.3, 00:02:22, Serial0/1/1
O IA 192.168.34.0/24 [110/128] via 192.168.23.3, 00:02:46, Serial0/1/1
以上输出表明路由器R2的路由表中既有区域内的路由“1.1.1.0”和“3.3.3.0”,又有区域间的路由“192.168.34.0”,还有外部区域的路由“4.4.4.0”。这就是为什么在R4 上要用重分布,就是为了构造自治系统外的路由。