15 
虚拟仿真──配置思科 DHCP

一、DHCP 基本配置

项目拓扑如图8-20所示。IP地址规划:R1的F0/0接口地址为192.168.1.1/24,这个地址作为下连PC机的网关。

图8-20 DHCP 基本配置

1.项目步骤

1配置路由器R1提供DHCP服务。

R1(config)#ip dhcp pool AAA                        !定义地址池

R1(dhcp-config)#network 192.168.1.0/24             !DHCP 服务器要分配的网络和掩码

R1(dhcp-config)#domain-name cisco.com              !域名

R1(dhcp-config)#default-router 192.168.1.1         !默认网关,这个地址要和相应网络所连接的路由器的以太口地址相同

R1(dhcp-config)#netbios-name-server 192.168.1.2    !WINS 服务器

R1(dhcp-config)#dns-server 192.168.1.4             !DNS 服务器

R1(dhcp-config)#option 150 ip 192.168.1.3          !TFTP 服务器

R1(dhcp-config)#lease infinite                     !定义租期

R1(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.5   !排除的地址段

2设置Windows客户端。

首先在Windows下把TCP/IP 地址设置为自动获得,如果DHCP服务器还提供DNS、WINS等,也把它们设置为自动获得。

2.项目调试

(1)在客户端测试。

在“命令提示符”下,执行C:/>ipconfig/renew可以更新IP地址。而执行C:/>ipconfig/all可以看到IP地址、WINS、DNS、域名是否正确。要释放地址,用C:/>ipconfig/release 命令。

(2)show ip dhcp pool。

该命令用来查看DHCP 地址池的信息。

R1#show ip dhcp pool

Pool A :

Utilization mark (high/low) : 100 / 0

Subnet size (first/next) : 0 / 0

Total addresses : 254              !地址池中共计254 个地址

Leased addresses : 2               !已经分配出去2 个地址

Pending event : none

1 subnet is currently in the pool :

Current index IP address range Leased addresses

192.168.1.8 192.168.1.1 - 192.168.1.254 2 !下一个将要分配的地址、地址池的范围以及分配出去的地址的个数
(3)show ip dhcp binding。

该命令用来查看DHCP的地址绑定情况。

R1#show ip dhcp binding

Bindings from all pools not associated with VRF:

IP address Client-ID/ Lease expiration Type

Hardware address/

User name

192.168.1.6 0063.6973.636f.2d Infinite Automatic

192.168.1.7 0100.6067.00dd.5b Infinite Automatic

以上输出表明DHCP服务器自动分配给客户端的IP地址以及所对应的客户端的硬件地址。

二、DHCP中继

项目验拓扑如图8-21所示。前期准备按照拓扑图配置网络设备和计算机的地址,并设置路由器时钟频率(具体操作略)。

图8-21 DHCP 中继配置

本项目中,R1仍然担任DHCP服务器的角色,负责向PC1所在网络和PC2所在网络的主机动态分配IP地址,所以R1上需要定义两个地址池。整个网络运行RIPv2协议,确保网络IP连通性。

1.项目步骤

1配置路由器R1提供DHCP服务。

R1(config)#interface FastEthernet0/0

R1(config-if)#ip address 192.168.1.1 255.255.255.0

R1(config-if)#no shutdown

R1(config)#router rip

R1(config-router)#version 2

R1(config-router)#no auto-summary

R1(config-router)#network 192.168.1.0

R1(config-router)#network 192.168.12.0

R1(config)#service dhcp

R1(config)#no ip dhcp conflict logging

R1(config)#ip dhcp pool aaa                        !定义第一个地址池

R1(dhcp-config)#network 192.168.1.0 /24

R1(dhcp-config)#default-router 192.168.1.1

R1(dhcp-config)#domain-name cisco.com

R1(dhcp-config)#netbios-name-server 192.168.1.2

R1(dhcp-config)#dns-server 192.168.1.4

R1(dhcp-config)#option 150 ip 192.168.1.3

R1(dhcp-config)#lease infinite

R1(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.5

R1(config)#ip dhcp pool bbb                         !定义第二个地址池

R1(dhcp-config)#network 172.16.1.0 255.255.255.0

R1(dhcp-config)#domain-name szpt.net

R1(dhcp-config)#default-router 172.16.1.2

R1(dhcp-config)#netbios-name-server 192.168.1.2

R1(dhcp-config)#dns-server 192.168.1.4

R1(dhcp-config)#option 150 ip 192.168.1.3

R1(dhcp-config)#lease infinite

R1(config)#ip dhcp excluded-address 172.16.1.1 172.16.1.2

2配置路由器R2。

R2(config)#interface FastEthernet0/0

R2(config-if)#ip address 172.16.1.2 255.255.255.0

R2(config-if)#ip helper-address 192.168.12.1          !配置帮助地址

R2(config-if)#no shutdown

R2(config)#router rip

R2(config-router)#version 2

R2(config-router)#no auto-summary

R2(config-router)#network 192.168.12.0

R2(config-router)#network 172.16.0.0
注意
路由器不能转发“255.255.255.255”的广播,但是很多服务(如DHCP、TFTP 等)的客户端请求都是以泛洪广播的方式发起的,我们不可能将每个网段都放置这样的服务器,因此使用Cisco IOS 帮助地址特性是很好的选择。通过使用帮助地址,路由器可以被配置为接受对UDP 服务的广播请求,然后将之以单点传送的方式发给某个具体的IP 地址,或者以定向广播的形式向某个网段转发这些请求,这就是中继。

2.实验调试

(1)show ip dhcp binding。

在PC1 和PC2 上自动获取IP 地址后,在R1 上执行:

R1#show ip dhcp binding

Bindings from all pools not associated with VRF:

IP address Client-ID/ Lease expiration Type

Hardware address/

User name

172.16.1.3 0100.6067.00dd.5b Infinite Automatic

192.168.1.6 0063.6973.636f.2d Infinite Automatic

192.168.1.7 0100.6067.00ef.31 Infinite Automatic

以上输出表明两个地址池都为相应的网络上的主机分配了IP地址。

(2)show ip dhcp pool。
R1#show ip dhcp pool

Pool aaa:

Utilization mark (high/low) : 100 / 0

Subnet size (first/next) : 0 / 0

Total addresses : 254

Leased addresses : 2

Pending event : none

1 subnet is currently in the pool :

Current index IP address range Leased addresses

192.168.1.8 192.168.1.1 - 192.168.1.254 2

Pool bbb :

Utilization mark (high/low) : 100 / 0

Subnet size (first/next) : 0 / 0

Total addresses : 254

Leased addresses : 1

Pending event : none

1 subnet is currently in the pool :

Current index IP address range Leased addresses

172.16.1.4 172.16.1.1 - 172.16.1.254 1